Some customers might experiencing issues with calling, messaging and meetings

Incident Report for Dialpad

Resolved

This incident has been resolved. Normal channels to Dialpad Support are now operational. Please visit https://www.dialpad.com/contact-us/ to contact Dialpad Support.
Posted May 20, 2025 - 09:51 PDT

Update

We are continuing to monitor the system. Normal channels to Dialpad Support are now operational. Please visit https://www.dialpad.com/contact-us/ to contact Dialpad Support.
Posted May 20, 2025 - 09:15 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 20, 2025 - 09:06 PDT

Update

We are continuing to investigate the issue.
If you are having difficulty contacting Dialpad Support, please visit https://help.dialpad.com and follow the instructions in the banner at the top of the page
Posted May 20, 2025 - 08:59 PDT

Update

We are continuing to investigate this issue.
Posted May 20, 2025 - 08:43 PDT

Investigating

We are currently investigating this issue.
Posted May 20, 2025 - 08:32 PDT
This incident affected: Telephony Infrastructure: Inbound Calls, Application, and Meetings.