Issues with Google login
Incident Report for Dialpad
Resolved
This issue should be resolved. If anyone continues to experience problems please reach out to Support.
Posted Apr 17, 2019 - 16:44 PDT
Update
We are continuing to investigate this issue.
Posted Apr 17, 2019 - 16:01 PDT
Investigating
We are currently seeing issues with Google login (https://status.cloud.google.com/incident/cloud-iam/19001). We are monitoring the situation and will update as we get more details
Posted Apr 17, 2019 - 15:45 PDT
This incident affected: Website.