We are investigating potential issues with our services impacting some Window users
Incident Report for Dialpad
Resolved
This issue should be resolved. If you continue to experience problems, please reach out to Dialpad Support for assistance.
Posted Jan 24, 2019 - 20:58 PST
Investigating
Our team is investigating reports of some Window users experiencing problems with launching the native app. We're making this a high priority, update to follow.
Posted Jan 24, 2019 - 14:19 PST