Investigating reports of calls not completing
Incident Report for Dialpad
Resolved
We identified an issue that affected a small percentage of calls. This has now been resolved.
Posted 5 months ago. Mar 08, 2017 - 09:41 PST
Investigating
We are investigating some reports of calls not completing.
Posted 5 months ago. Mar 08, 2017 - 08:58 PST