Current service issues under investigation
Incident Report for Dialpad
Resolved
This issue is now resolved.
Posted 17 days ago. Nov 06, 2017 - 15:59 PST
Monitoring
Update: all systems clear. Still Monitoring. Update soon.
Posted 17 days ago. Nov 06, 2017 - 14:24 PST
Update
Update - Dialpad and UberConference are aware of the nationwide IP connnectivity outage affecting multiple service providers. We are monitoring the situation and will keep you posted here at 2:40pm PST.

Google is experiencing an issue with Memcache availability beginning at November 6, 2017 at 12:30 pm US/Pacific. Current data indicates that all projects using Memcache are affected by this issue. For everyone who is affected, we apologize for any inconvenience you may be experiencing.
https://status.cloud.google.com/incident/appengine/17007
Posted 17 days ago. Nov 06, 2017 - 14:12 PST
Investigating
We are currently investigating this issue.
Posted 17 days ago. Nov 06, 2017 - 11:58 PST