Dialpad Contact Us Form is Unavailable

Incident Report for Dialpad

Resolved

This incident has been resolved.
Posted Nov 12, 2019 - 15:30 PST

Identified

We've had several reports that our contact us page (https://dialpad.com/contact-support) is currently not generating tickets for our customers. We're working to resolve this, you can still get in touch with us via direct email, chat, and phone. Thank you for your patience.
Posted Nov 12, 2019 - 13:47 PST