Support via Chat is currently experiencing delays
Incident Report for Dialpad
Resolved
This incident has been resolved.
Posted Sep 01, 2020 - 10:47 PDT
Identified
Our support team is currently experiencing technical issues with our chat function. We are aware of the issue and hope to have it resolved soon. Should you need to reach out to Dialpad Support please call us or email us at Support@dialpad.com.
Posted Sep 01, 2020 - 09:27 PDT
This incident affected: Website.