Live Dashboard filter period change not working as expected
Incident Report for Dialpad
Resolved
As of 15:25 UTC, the issue is resolved
Posted Jul 03, 2024 - 08:29 PDT
Identified
We have identified the issue, and our team is currently working to resolve it as quickly as we can.
Posted Jul 03, 2024 - 08:13 PDT
Investigating
The Live Dashboard filter period adjustment isn't functioning correctly; our engineers are investigating the issue.
Posted Jul 03, 2024 - 07:01 PDT
This incident affected: Analytics.