Some customers in North America may have experienced issues with calls

Incident Report for Dialpad

Resolved

This incident has been resolved.
Posted May 09, 2025 - 10:50 PDT

Investigating

We are currently investigating this issue.
Posted May 09, 2025 - 10:39 PDT

Monitoring

Issue impacted a percentage of calls in North America between 16:20 and 16:46 UTC. A fix has been implemented and we are monitoring the situation.
Posted May 09, 2025 - 10:31 PDT
This incident affected: Telephony Infrastructure: Inbound Calls and Telephony Infrastructure: Outbound Calls.