Issues accessing www.Dialpad.com
Incident Report for Dialpad
Resolved
This incident has been resolved.
Posted Dec 19, 2022 - 19:00 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 19, 2022 - 18:13 PST
Update
We are continuing to work on a fix for this issue. Users can continue accessing the website at www.dialpad.com/login or the Desktop/Mobile app.
Posted Dec 19, 2022 - 16:02 PST
Identified
The issue has been identified and a fix is being implemented. In the meantime, any user experiencing an issue logging in can use the following link:

https://dialpad.com/login
Posted Dec 19, 2022 - 15:23 PST
Investigating
www.dialpad.com is experiencing issues and we are investigating. Existing Customers can continue using www.dialpad.com/login or our Desktop/Mobile app. There is no impact to the service.
Posted Dec 19, 2022 - 14:49 PST
This incident affected: Website.