Some customers may be experiencing issues with CTI calling features.

Incident Report for Dialpad

Resolved

This incident has been resolved.
Posted Jun 18, 2025 - 21:01 PDT

Monitoring

A fix has been rolled out, and refreshing the CTI will resolve the issue.
Posted Jun 18, 2025 - 15:20 PDT
This incident affected: Integrations.