Outbound Fax Services Unavailable
Incident Report for Dialpad
Resolved
Fax service has been restored and new outbound faxes should transmit successfully.
Posted 12 days ago. May 14, 2019 - 14:53 PDT
Update
We are continuing to work on a fix. We appreciate your patience.
Posted 13 days ago. May 13, 2019 - 14:58 PDT
Identified
The issue has been identified and our team is working with our partner toward resolution.
Posted 13 days ago. May 13, 2019 - 10:38 PDT