Dialpad login button is redirecting to blank page
Incident Report for Dialpad
Resolved
The issue has rectified at 7:39 PST
Posted May 06, 2024 - 07:55 PDT
Monitoring
Corrective action is in place and we are monitoring the situation very closely
Posted May 06, 2024 - 07:49 PDT
Update
We are continuing to work on a fix for this issue.
Posted May 06, 2024 - 07:41 PDT
Identified
We have identified an issue with the Dialpad login button redirecting to a blank page. As a workaround please go directly to https://dialpad.com/login
Posted May 06, 2024 - 07:39 PDT
This incident affected: Website.