Some customers in Australia and New Zealand may be experiencing issues with calls or meetings

Incident Report for Dialpad

Resolved

This incident has been resolved.
Posted Apr 11, 2025 - 00:11 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 11, 2025 - 00:01 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 10, 2025 - 23:44 PDT

Investigating

We are currently investigating this issue.
Posted Apr 10, 2025 - 23:26 PDT
This incident affected: Telephony Infrastructure: Inbound Calls and Telephony Infrastructure: Outbound Calls.