[Outage] Chat with us link in our Contact Support page is not working.
Incident Report for Dialpad
Resolved
This incident has been resolved.
Posted Mar 20, 2023 - 20:02 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 20, 2023 - 19:50 PDT
Update
We are continuing to investigate this issue.
Posted Mar 20, 2023 - 19:30 PDT
Investigating
We are investigating an issue accessing the Chat support using the "Chat with us” link. In the meantime, you can still access our Chat support by clicking the Dialpad icon on the bottom right corner of the page.
Posted Mar 20, 2023 - 19:28 PDT
This incident affected: Contact Center.