Some customers may be experiencing issues with making and receiving calls.

Incident Report for Dialpad

Resolved

This incident has been resolved.
Posted Jun 04, 2025 - 20:51 PDT

Update

We are continuing to investigate this issue.
Posted Jun 04, 2025 - 19:18 PDT

Investigating

We are currently investigating this issue.
Posted Jun 04, 2025 - 19:17 PDT
This incident affected: Telephony Infrastructure: Inbound Calls, Telephony Infrastructure: Outbound Calls, and Meetings.