Logging in with Google
Incident Report for Dialpad
Resolved
Google authentication appears to be resolved. If you continue to experience issues please contact Support.
Posted 3 months ago. Dec 04, 2018 - 15:59 PST
Investigating
Dialpad Team is monitoring reports that some users experiencing issues with Google authentication. Update to follow.
Posted 3 months ago. Dec 04, 2018 - 15:12 PST
This incident affected: Website.